设为首页 - 收藏本站 欢迎访问: 股粉帮(www.guofenb.com) - 免费下载通达信大智慧等股票公式,指标,股池并进行投资交流!交流QQ群:891842347
热搜: 选股副图主图文华公式
当前位置:首页 >>新手上路 >>选股方法 >> ​13种经典K线形态选股方法

​13种经典K线形态选股方法

2019年02月17日 [选股方法] 浏览:599 评论:0

13种经典K线形态选股方法:

{抄底栏胸-上升形态---曙光初现(反击线)}      
抄底栏胸:=REF(C,1)/REF(O,1)<=0.96 AND O< REF(C,1) AND C/O>1.05 OR REF(C,1)/REF(O,1)<=0.96 AND O< REF(C,1) AND C/O>1.05  AND O!=H AND C!=L AND (C-L)>(H-C) ;
{高开高收-上升形态}
高开高收:=REF(C,1)/REF(O,1)<=0.96 AND O> REF(O,1) AND C/O>1.04 OR REF(C,1)/REF(O,1)<=0.96 AND O> REF(O,1) AND C/O>1.04  ;
{抄底罩顶-上升形态---旭日东升}
抄底罩顶:=REF(C,1)/REF(O,1)<=0.96 AND O< REF(C,1) AND C/O>1.05 AND C>REF(H,1)   ;
{ 岛型反转-反转形态}
岛型反转:=REF(C,5)<REF(O,5)  AND REF(O,4)< REF(O,5) AND REF(C,4)< REF(C,5) AND REF(C,4)<REF(O,4)   {【前4日}
AND REF(O,3)< REF(O,4)  AND REF(C,3)< REF(C,4) AND REF(O,3)<REF(C,3)   {【前3日}  
AND  REF(O,2)< REF(O,3) AND REF(C,2)< REF(C,3) AND REF(C,2)<REF(O,2)   {【前2日} {前4阴}  
AND REF(O,1)>REF(O,2) AND REF(C,1)> REF(C,2)  AND REF(C,1)>REF(O,1)    {【前1日}
AND  O> REF(C ,1) AND  C>REF(C,1)  AND C/O>1.05    {【当日} ;  
{吞没二阳-上升形态}
吞没二阳:=REF(C,2)/REF(O,2)<=0.96  AND  O> REF(C,2) AND  REF(C,1)/REF(O,1)>1.05  AND O< REF(C,1) AND C/O>1.05;
{星上阳线-上升形态  }
A:=ABS(REF(C,1)/REF(O,1))<0.98;
下影线:=(MIN(O,C)-L)/L*100;
上影线:=(H-MAX(O,C))/MAX(O,C)*100;
十字星:=下影线/上影线>0;
B:=A AND 十字星;
星上阳线:=B AND} ABS(C-O)/O<0.02 AND O> REF(C,1) AND C/O>1.05;  ;
{压星阳线-上升形态}
压星阳线:={B AND}  ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND OPEN> MAX(REF(OPEN,1),REF(CLOSE,1)) AND CLOSE/OPEN>1.04;
{吞星阳线-上升形态}
吞星阳线:=ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND OPEN>REF(L,1) AND CLOSE> REF(H,1) AND CLOSE/OPEN>1.04;
{吞没阳线-反转形态}
吞没阳线:=REF(CLOSE,1)/REF(OPEN,1)<0.96 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(OPEN,1) AND CLOSE/OPEN>1.05;
{上贯穿线-反转形态}
上贯穿线:=(REF(CLOSE,1)/REF(OPEN,1)<0.96 AND OPEN<REF(CLOSE,1)) AND CLOSE>ABS(REF(OPEN,1)- REF(CLOSE,1))/2 AND CLOSE/OPEN>1.05;  {【上贯穿线 上穿 前日阴线实体的下点和实体的中点}
{闺中乳燕-空头气竭-反转形态}
T1:=REF(C,3)<REF(O,3)  AND  REF(C,3)/REF(O,3)<0.96 ;  {【1K  }
T2:=REF(O,2)<REF(C,3) AND REF(C,2)<REF (O,2) AND REF(C,2)/REF(O,2)<0.96;  {【2K  }
T3:=REF(O,1)<REF(C,2) AND REF(O,1)/REF(C,1)<0.98 AND (H-MAX(REF(O,1),REF(C,1))/MAX(REF(O,1),REF(C,1)))*100>1.04
OR REF(O,1)/REF(C,2)>1.02 AND (H-MAX(REF(O,1),REF(C,1))/MIN(REF(O,1),REF(C,1)))*100>1.04;  {【3K  }
T4:=OPEN>REF(H,1) AND C<O AND C/O<0.98;   {【4K }
闺中乳燕:=T1 AND T2 AND T3 AND T4;      {【待优化}
{内困三日翻红-母子确认-反转形态}
U1:=REF(C,2)<REF(O,2)  AND  REF(C,2)/REF(O,2)<0.91 ; {【1K  }
U2:=REF(O,1)>REF(C,2) AND REF(C,1)>REF(O,1)  AND  REF(C,1)/REF(O,1)<1.02 AND REF(C,1)/REF(O,1)<1.02; {【2K  }
U3:=O<REF(C,1) AND C/O>1.04 {AND (H-MAX(REF(O,1),REF(C,1))/MAX(REF(O,1),REF(C,1)))*100>1.04};        {【3K}
内困三日红:=U1 AND U2 AND U3 ;         {【 待优化};
{三明治-空头将尽-确认-有可能反转}
三明治:=REF(CLOSE,2)/REF(OPEN,2)<0.96 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(CLOSE,1)>REF(OPEN,2) AND  OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,2) AND  CLOSE/OPEN<0.93;  {【空头将尽}

选股:抄底栏胸  OR 高开高收   OR 抄底罩顶   OR 岛型反转   OR 吞没二阳   OR 星上阳线 OR  压星阳线  
OR 吞星阳线   OR 吞没阳线   OR 上贯穿线   OR 闺中乳燕   OR 内困三日红  OR 三明治 ;


(编辑:股粉帮)

发表我的评论换个身份
取消评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
热评文章
二维码