设为首页 - 收藏本站 欢迎访问: 股粉帮(www.guofenb.com) - 免费下载通达信大智慧等股票公式,指标,股池并进行投资交流!交流QQ群:891842347
热搜: 选股副图主图文华公式
当前位置:首页 >>公式股池 >>公式解答 >> MDI、ADX、ADXR三线金叉选股公式

MDI、ADX、ADXR三线金叉选股公式

2019年11月02日 [公式解答] 浏览:588 评论:0
编写要求:DMI指标中的 PDI在30以下运行时,某日PDI快速同时向上穿过MDI、ADX、ADXR三线时给出选股。


股粉帮(www.guofenb.com)解答:

DD:=30;{PDI在30下天数}
N:=14;
MM:=6;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,MM);
ADXR:=EXPMEMA(ADX,MM);
XG:REF(EVERY(PDI<30,DD),1) AND CROSS(PDI,MDI) AND CROSS(PDI,ADX) AND CROSS(PDI,ADXR);


(编辑:股粉帮)

发表我的评论换个身份
取消评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
热评文章
二维码