设为首页 - 收藏本站 欢迎访问: 股粉帮(www.guofenb.com) - 免费下载通达信大智慧等股票公式,指标,股池并进行投资交流!交流QQ群:891842347
热搜: 副图选股主图文华公式
当前位置:首页 >>公式股池 >>公式解答 >> 涨停回马枪选股公式指标

涨停回马枪选股公式指标

2021年12月18日 [公式解答] 浏览:71 评论:0

涨停回马枪选股公式指标:

编写要求:

涨停回马枪源码: DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); DEA:=EMA(DIFF,9); MACD:=2*(DIFF-DEA); TS:=BARSLAST(C/REF(C,1)>1.085);{上一个涨停距今天数} A2:=IF(REF(L,TS)>REF(H,TS+1),REF(C,TS+1),REF(O,TS));{涨停当天最低价} A3:=BETWEEN(TS,2,13); {天数条件} A4:=C>=A2 AND BETWEEN(L/A2,1.035,0.97);{价格条件} A5:=V=A2;{单阳不破} A8:=MACD>-1;{MACD条件} 左侧低吸: A3 AND A4 AND A5 AND A6 AND A7 AND A8; A9:=MA(C,5)>=A2 AND C>A2 AND C>=MA(C,5) AND REF(C,1)<=REF(MA(C,5),1) AND LLV(L,TS)0 AND A9; 要求:以下图示中的股票能有信号出来,谢谢!

股粉帮(www.guofenb.com)解答:

 DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
TS:=BARSLAST(C/REF(C,1)>1.085);{上一个涨停距今天数}
A2:=IF(REF(L,TS)>REF(H,TS+1),REF(C,TS+1),REF(O,TS));{涨停当天最低价}
A3:=BETWEEN(TS,2,13); {天数条件}
A4:=C>=A2 AND BETWEEN(L/A2,1.035,0.97);{价格条件}
A5:=V<REF(V,1) AND V<MA(V,5);{成交量条件}
A6:=ABS(C/O-1)*100<5;{K线条件}
A7:=LLV(C,TS)>=A2;{单阳不破}
A8:=MACD>-1;{MACD条件}
左侧低吸:  A3 AND A4 AND A5 AND A6 AND A7 AND A8;
A9:=MA(C,5)>=A2 AND C>A2 AND C>=MA(C,5) AND {REF(C,1)<=REF(MA(C,5),1)
AND }LLV(L,TS)<A2*1.045;
右侧突破: REF(A3,1)>0 AND A9;


(编辑:股粉帮)

发表我的评论换个身份
取消评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
热评文章
二维码