设为首页 - 收藏本站 欢迎访问: 股粉帮(www.guofenb.com) - 免费下载通达信大智慧等股票公式,指标,股池并进行投资交流!交流QQ群:891842347
热搜: 选股副图主图文华公式
当前位置:首页 >>公式股池 >>大智慧公式 >> 大智慧宝塔线主图指标公式

大智慧宝塔线主图指标公式

2020年09月29日 [大智慧公式] 浏览:64 评论:0

大智慧宝塔线主图指标公式:

input:n(26,5,300),p(2,0.1,10);
DRAWGBKlast(c>0,strip(RGB(0,40,0),RGB(0,20,20),1)),LAYER0;
x:=(3*c+l+o+h)/6;
{2.BOLL}
MID : MA(X,N) ,COLOR00ff00,DOTLINE;
UPPER: MID + P*STD(X,N) ,COLOR0000FF,DOTLINE;
LOWER: MID - P*STD(X,N) ,COLOR00FFff,DOTLINE;
收盘价格:C,POINTDOT;
B0:=REF(C-O,2);B1:=REF(C,1);
B2:=REF(C,2);B3:=REF(C,3);B4:=REF(C,4);
CMAX:=MAX(MAX(MAX(C,B1),B2),B3);
CMIN:=MIN(MIN(MIN(C,B1),B2),B3);
STICKLINE(C=CMAX AND (B1>=B2 OR B1>=B3) OR B1=CMAX AND (B2=CMIN OR B3=CMIN) AND C>=B2 OR
B2=CMAX AND B3=CMIN AND C>=B1 OR B3=CMAX AND C>=B1 AND C>=B2,B1,C,5,0),COLORRED,LAYER0;
STICKLINE(C=CMAX AND B1=CMIN,B2,C,5,0),COLORRED,LAYER0;
STICKLINE(C=CMIN AND (B1<B2 OR B1<B3) OR B1=CMIN AND (B2=CMAX OR B3=CMAX) AND C<B2 OR
B2=CMIN AND B3=CMAX AND C<B1 OR B3=CMIN AND C<B1 AND C<B2,B1,C,5,0),COLORGREEN,LAYER0;
STICKLINE(B1=CMAX AND C=CMIN,B2,C,5,0),COLORGREEN,LAYER0;
STICKLINE(B1=CMIN AND C>=B2 OR (B2=CMIN AND B1<=B3 OR
B3=CMIN AND B1<=B2) AND B2<B4 AND C>=B1,B1,B2,5,0),COLORGREEN,LAYER0;
STICKLINE(B1=CMAX AND C<B2 OR (B2=CMAX AND B1>B3 OR
B3=CMAX AND B1>B2) AND B2>=B4 AND C<B1,B1,B2,5,0),COLORRED,LAYER0;
ma5:ma(c,5),Color00FF00,DOTLINE;
DD5:=MA5>REF(MA5,1);
{www.gUPaNg.com 股旁网_最新股票指标公式}
PARTLINE(MA5,DD5),Color0000FF,linethick2;
多空线:(20*x+19*ref(x,1)+18*ref(x,2)+17*ref(x,3)+16*ref(x,4)+15*ref(x,5)+14*ref(x,6)
+13*ref(x,7)+12*ref(x,8)+11*ref(x,9)+10*ref(x,10)+9*ref(x,11)+8*ref(x,12)
+7*ref(x,13)+6*ref(x,14)+5*ref(x,15)+4*ref(x,16)+3*ref(x,17)+2*ref(x,18)+
ref(x,20))/210,coloryellow,linethick0;
DD:=多空线<REF(多空线,1);
PARTLINE(多空线,DD),colorffffff,DOTLINE;
A:=(MA5>多空线);
PARTLINE(多空线,A),COLORYELLOW,linethick3;
A1:=(MA5<多空线);
PARTLINE(多空线,A1),COLORWHITE,DOTLINE;
XP:=BARSLAST(DISPSTATUS=1)+1;
E:=llvall(llv(l,XP))*0.95;
多空线M:EMA(多空线,3);
多空 :多空线M-REF(多空线M,1) ,LINETHICK0;;
STICKLINE(多空>0,E+多空*5,E,18,0),Color0000FF;
STICKLINE(多空<0,E+多空*5,E,18,0),Color00FF00;
DRAWGBK(多空>0 ,STRIP(RGB(0,0,255),RGB(140,0,100),0)),LAYER0;
FILLRGN(UPPER,MID,UPPER>MID AND 多空>0,RGB(40,0,100)),LAYER5;
VERTLINE(CROSS(REF(WMA(C,18),1),WMA(C,18)) AND 多空>0,2),LAYER0,COLOR00FFFF;

(编辑:股粉帮)

发表我的评论换个身份
取消评论

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
热评文章
二维码